Like Ra in latex catsuit, latex mask and high heels
Like Ra's Naughty Playground

New donation goal

The site is hosted by Linode and costs 480$ per year. In order to allow backups (+$10 monthly), the new goal is $600 yearly.

Thanks much again to those who already donated!

$275

You can also support the site at no cost to you by using these links shopping:

Aliexpress or eBay

[read more…]



Upgrading the operating system

Update @22:34: Upgraded! Please let me know if something is broken. You can use this forum thread: Site performance, Server errors, outages and tunings

The operating system on the server will be upgraded in a couple of hours. Please be aware of the downtime.



The server/site has been upgraded!

Yesterday the site was moved to a new server! Now we have 2GB of RAM (was 1GB), 8 core E5-2650L Xeon @1.8GHz 20MB cache CPU (was 4 core L5520 Xeon @ 2.27GHz 8MB cache), 48 GB or storage space (was 40GB), 4TB(!!!!) of monthly transfer (was 400GB), 10Gb/s Ethernet infrastructure (was 1Gb/s), new disks with more cache.

Not bad, huh? The most important upgrade is the RAM. One extra Gigabyte allows more possible connections and more cache (APC, pagespeed, MySQL). Not much, actually, you may not even notice the improvements (I think the latency decreased by 10-15%), but now we have more breathing space, more overload protection, more stability and almost unlimited bandwidth.

For example, as long as nobody’s ripping the whole site (I immediately block such IP addresses), the PHP content is served entirely from the APC cache (100% hit rate)!

See also Site performance, Server errors, outages and tunings



Do not use free image hosting services

I should’ve done it earlier, but since everything was working fine I decided to wait and concentrate on updates. But bloody Photobucket changed the way they addressed thumbnails, and as a result all linked pics disappeared from posts.

I’m removing everything related to these morons (who block classic art should a naked breast appear there), but it’s gonna take days.

That’s another lesson about the same rule – do not use free image hosting services. Sooner or later they will betray you.



Tweaking the web-server again

Updated on Oct 21, 2012 @ 16:20:: Completed. I will continue to experiment with minor tweaks, but no major shutdowns are expected. See also Site performance, Server errors, outages and tunings
And yes, 1GB RAM is not enough ;-)

Updated on Oct 20, 2012 @ 19:02: upgraded OS to the latest release. Looks like everything is still working. Next step is to make an attempt to migrate from MPM ITK + mod_php to MPM Worker (or even Events) + fcgid. Way too many things to consider … Or possibly Nginx? ;-)

Published on: Oct 20, 2012 @ 15:07: I’m going to take the web-server apart again. No particular time. Just be aware and “reload” a minute later if the site is not responding.



Testing new performance features

Update: OK, I’m done with tweaking. let me know what you think ;-)

I’m testing new performance related features. It is possible that something will appear broken or simply stops working.



Blog for mobile devices

Another attempt to make the blog more mobile devices friendly. Please let me know if you would like to add/change/improve anything.



Site news

Some of you may wonder why there are no new blog posts since … hmmm.. a months ago. A short answer is: “No time, no energy, no inspiration”.

A long answer is a bit longer ;-)

  • Last month I was overloaded with my work, then trainings and last but not least: some family obligations. All these activities left almost no time for anything else (see the short answer)
  • When I have no inspiration I switch to other boring, tedious, but absolutely necessary tasks like system administration, redesigning and restructuring. For example, the tasks below.
  • System, software and forum upgrade
  • Forum restructuring
  • Added sub-forums for shops reviews (a long awaited feature)
  • New forum features
  • New games and new version of the SuperDeepThroat game
  • Revisited the completed self-bondage sessions posted in the forum and updated the index/table of content
  • Removed some more ads
  • Revisited links and moved them under the Blog control, so they can be easier maintained and automatically checked for existence.

More ideas, comments or complaints? Please let me know!



The forum is not working at the moment

Updated on May 04, 2012 @ 13:20:
One sleepless night and it’s fixed ;-) For some reason the plugin wiped out the template, theme and stylesheet database tables. I recovered them from the backup I made right before the upgrade (so they might be not up-to-date). And since I was already messing up with the design, I fixed more things I did not have time for before the crash.

As always, please let me know if anything is still broken or if you have suggestions to change/improve the layout, menu, etc.

Posted on May 03, 2012 @ 21:29:
The forum is not working for some reason. “White screen of death”. I suspect the Google SEO plugin and PluginLibrary. No errors in the error logs. Investigating…



Upgrading the operating system

Updated on May 01, 2012 @ 00:35:
OK, so this is what was done:
o- OS (kernel, applications, drivers, etc) is upgraded
o- reconfigured the Xen kernel loader, so a “non-standard” (not predefined by the hoster) kernel can be booted up
o- Apache (web-server) is upgraded
o- MySQL (the database) is upgraded
o- WordPress (blog software) is upgraded
o- MyBB is upgraded
o- MyBB extensions are upgraded (see more details in the forum news sub-forum)

See also: Site performance, Server errors, outages and tunings

Please let me know if something is broken.

Posted on Apr 26, 2012 @ 17:35:
The site will be down for a couple of hours for the OS upgrade.